Home Forums BP Better Messages Can I set up a manual cron instead of standard wp cron

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #13021
    Claus Andersen
    Participant

    Hi I have deactivated standard wp cron for performance reasons. Can I add the cron jobs manual for sending out notifications. It seems like no notifications are sent right now.

    In plugin settings I have chosen the send out every 15 mins option, but it is not working, and I think it is because I am not using the standard wp cron and I can’t seem to find an url to set it up myself.

    Best regards

    #13022
    Support
    Keymaster

    Hi there!

    To debug the cron job, highly recommend the WP Crontrol plugin:

    WP Crontrol


    It will show if your cron jobs works properly or not.

    Also notice that plugin does not sends already read messages in emails and does not send notifications while user is online.

    Thanks!

    #13024
    Claus Andersen
    Participant

    Thanks, I will try this.

    Also I just noticed that the timezone in the area where admin can read messages, is two hours off compared to the rest of the site.

    Right now the timestamp is 11:10 if sending a message, but the rest of the site is +2 hours “13:10”.

    Will this also affect the sending notifications every 15 mins. And can I edit the timezone somewhere in plugin settings.

    #13025
    Claus Andersen
    Participant

    I’ve just found this error when executing cron.

    Task “httpdocs/wp-cron.php” completed with error in 1 seconds, output:

    PHP Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 69632 bytes) in /var/www/vhosts/XXXXXXXXXXX/httpdocs/wp-content/plugins/bp-better-messages-websocket/vendor/emojione/src/Ruleset.php on line 7295

    Best regards

    #13026
    Claus Andersen
    Participant

    Installed the plugin you’ve suggested, and for some reason cron is not working when better messages websocket plugin is activated.

    Tried a manual run and it gives my this message

    Foto

    Best regards

    #13029
    Support
    Keymaster

    Hi there!

    Seems like there is no enough PHP memory limit for your website.

    Increase PHP memory limit to 256MB or more at your hosting PHP settings.
    That should fix the problem.

    https://www.wpbeginner.com/wp-tutorials/fix-wordpress-memory-exhausted-error-increase-php-memory/

    Thanks!

    • This reply was modified 2 months ago by Support.
    • This reply was modified 2 months ago by Support. Reason: added link
Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.